Введение

Снимок экрана 2020-10-23 152622

Стрим-сервер представляет из себя высоконадежную систему просмотра видеокамер и их записи.

Он почти не потребляет вычислительных ресурсов, поэтому может быть установлен даже на слабом ПК. Как на Windows, так и на Linux. Он может работать с большим количеством дисков, обеспечивая длительное хранение видеоконтента.

Стрим-сервер работает и как DVR, складывая видео без распаковки в потоковых кодеках типа H.264. Каждый участок архива, каждый его кадр может быть ассоциирован с любым событием и запрошен на просмотр любым сетевым клиентом.

Сами камеры в реальном времени могут просматриваться любым количеством сетевых клиентов как через обычный браузер, так и в специализированных программах. Тем самым Стрим-сервер является расширителем доступа к камерам, которые способны выдавать только несколько каналов.

Если IP-камера, как правило, позволяет выдать только два потока видео в разных форматах или только один поток в нужном формате, то Стрим-сервер обеспечивает размножение любых типов потоков на большое количество.

Такая автономная задача, обрабатываемая на отдельном дешевом компьютере, позволяет высвободить ресурсы видеосерверов и АРМ-ов, многократно повысить эффективность видеоаналитики и уменьшить затраты на её ресурсы.


Работа со стрим сервером в браузере

1. Запуск и ввод учетных данных

Откройте интернет браузер и наберите в адресной строке адрес стрим-сервера. Например: http://192.168.10.124:8888/

Введите логин/пароль от аккаунта. Учетные данные можно получить у вашего системного администратора.

После ввода учетных данных, кликните в окно камеры по надписи «Кликните для начала просмотра».

2. Добавление камеры в окно просмотра

Чтобы добавить камеру в окно, перетащите с зажатой ЛКМ необходимый поток/архив в окно справа от списка камер.

3. Работа с видами

Для смены количества отображаемых камер/архивов раскройте список «Виды» и включите необходимый вид кликнув по нему ЛКМ.

Снимок экрана 2020-10-20 121652

4. Просмотр архива

Чтобы просмотреть архив, перетащите его с зажатой ЛКМ в окно справа от списка камер. Для удобства просмотра, записи в архиве разбиты на минутные интервалы. Для просмотра архива за интересующий вас интервал времени, выберите дату, час и кликните ЛКМ на нужном минутном интервале.

Снимок экрана 2020-10-22 111142